This version of vCenter Server does not support Deploy OVF Template

Shares

If you are running VMware vCenter 6.5 Build Number 4944578 or below and you try to deploy an OVF template via the vSphere Web interface, you will most likely experience this error:

“This version of vCenter Server does not support Deploy OVF Template using this version of vSphere Client. To Deploy OVF Template, login with version 6.5.0.0 of vSphere Web Client”

vcenter-6-5-cannot-deploy-ovf-template

VMware vCenter 6.5 cannot deploy OVF Template

After a bit of research within the VMware communities, I came across a post that states, upgrading to vCenter 6.5.0b resolves this issue. I entered into the vServer Server Appliance admin interface, checked for updates, and installed updated version 6.5.0 Build 5178943 (vCenter 6.5.0b)

vcenter6-5-upgrade-to-6-5-0-b

 

VMware vCenter 6.5.0b can now deploy OVF templates via the Web Interface

Now, when I right click within the left navigator window and select Deploy OVF template, I no longer get the above error message and can successfully deploy an OVF template.

vcenter-6-5-0-b-deploy-ovf-template